当前位置: 网站首页 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码:KDJ新改指标+陶氏买卖+短线终结者副图

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

KDJ新改指标:

cs=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
a=EMA(cs,3,1);
b=EMA(a,2,1);
e=3*a-2*b;
LOWV:=LLV(LOW,8);
HIGHV:=HHV(HIGH,8);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
上:=EMA(RSV,3),colorlimagenta;
下:=MA(上,3),colorliblue;
A1:=BARSLAST(REF(CROSS(e,b),1));
底:=REF(CLOSE,A1+1)>CLOSE AND e>REF(e,A1+1) AND CROSS(e,b);
A2:=BARSLAST(REF(CROSS(b,e),1));
顶:=REF(CLOSE,A2+1)<CLOSE AND REF(b,A2+1)>b AND CROSS(b,e);
DRAWTEXT(CROSS(上,18),20,'加'),colorcyan;
DRAWTEXT(CROSS(上,78),80,'警'),coloryellow;
DRAWTEXT(CROSS(96,e) AND (e<=80),60,'回调'),colorred;
DRAWTEXT(CROSS(e,1) AND (e<=20),40,'反弹'),colorbrown;
DRAWTEXT(底>0,-10,'KDJ底'),colorgreen;
DRAWTEXT(顶>0,100,'KDJ顶'),COLORFF00FF;
趋势线:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))
*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))
*100,5,1),3,1),5),LINETHICK2,colorred;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSIE:=EMA(RSI,3);
DIFF :=EMA(RSIE,12) - EMA(RSIE,26);
BBDIFF:=DIFF-REF(DIFF,1);
DEA :=EMA(DIFF,9);
BBDEA:=DEA-REF(DEA,1);
A3:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A3+1)>CLOSE AND DIFF>REF(DIFF,A3+1) AND
CROSS(DIFF,DEA);
A4:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A4+1)<CLOSE AND REF(DIFF,A4+1)>DIFF AND
CROSS(DEA,DIFF);



陶氏买卖:


该指标用于成功抄底和逃顶,能精准半段支撑位和压力位,能准确判断是反弹还是大涨,回调还是下降。

 DRAWBAND(MA(CLOSE,60),RGB(200,100,160),MA(CLOSE,120),RGB(0,200,0));

DRAWBAND(MA(CLOSE,5),RGB(200,0,0),MA(CLOSE,10),RGB(0,200,0));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),colorwhite;
MA10:MA(CLOSE,10),coloryellow;
MA20:MA(CLOSE,20),colormagenta;
MA60:MA(CLOSE,60),colorcyan,LINETHICK2;
MA120:MA(CLOSE,120),colorblue,LINETHICK3;
DRAWICON(CROSS(MA10,MA20),MA20,1);
DRAWICON(CROSS(MA20,MA60),MA60,1);
DRAWICON(CROSS(MA20,MA120),MA120,1);
DRAWICON(CROSS(MA60,MA120),MA60,1);
DRAWICON(CROSS(MA10,MA5),MA10,2);
DRAWICON(CROSS(MA20,MA10),MA20,2);
DRAWICON(CROSS(MA60,MA20),MA60,2);
DRAWICON(CROSS(MA120,MA60),MA60,2);
反弹:=MA5>MA10 AND MA10>MA20 AND MA20<MA60 AND MA60<MA120 AND CROSS(MA10,MA20);
熊来:=MA60<MA120 AND MA60<MA120 AND CROSS(MA120,MA60);
DRAWTEXT(反弹,MA20-0.08,'反弹'),colormagenta;
DRAWTEXT(熊来,MA60+0.08,'注意熊'),colorgreen;
VOL5:=MA(VOL,5),colorwhite;
VOL10:=MA(VOL,10),coloryellow;
VOL40:=MA(VOL,40),COLORFF00FF ;
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;
TM:=V-MA(V,10);
C6:=REF(C,1);
涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),colormagenta;
STICKLINE(涨停,H,L,0,0),colorlired;
TY:=C;//70822.com
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),colorblue;
 


短线终结者副图(顶尖财经 股票学院: http://58188.com):

卖出既是买入,S是止损。一二六线顺上缩踩不漂,BBI通气是条件。

VAR0:=SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,5,1);
波段线:EMA(VAR0,3),coloryellow,NODRAW;
VAR1:=EMA(波段线,2);
VAR2:=EMA(VAR1,2);
VAR3:=CROSS(VAR1,VAR2);
VAR4:=CROSS(VAR2,VAR1);
STICKLINE(波段线>20 AND 波段线<50,波段线-2,波段线+2,5,0),coloryellow;
抄底:=IF(CROSS(波段线,8) OR CROSS(波段线,15),波段线*3.0,0),colorblue;
节节高:=IF(VAR4,波段线,0),colorblue,NODRAW;
DRAWTEXT(VAR3 AND VAR1>20,波段线-12,'买'),colorred;
STICKLINE(VAR3 AND VAR1>20,波段线,0,1,0),colorred;
STICKLINE(波段线>80,波段线-2,波段线+2,5,0),colorred;
STICKLINE(波段线<20,波段线-2,波段线+2,5,0),colorblue;
STICKLINE(波段线>50 AND 波段线<80,波段线-2,波段线+2,5,0),colormagenta;
DRAWTEXT(抄底>1,抄底+5,' 抄底'),coloryellow;
DRAWICON(抄底>1,抄底,4);
 
...........

上一篇:同花顺指标:上轨回调中轨主图+江恩分段主图

下一篇:同花顺源码:大将快牛线+放量上攻+大牛启动点

推荐阅读