当前位置: 网站首页 > 股票软件公式 > 同花顺公式 > 文章 当前位置: 同花顺公式 > 文章

同花顺源码:黑马出击,机构利器,超准波段指标

点击: 次    来源:顶尖财经    作者:股市狙击 - 小 + 大

1、黑马出击,你恐慌我贪婪,出击抄底

黑马出击_

VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);

VAR2:=VAR1,colorred,LINETHICK2;

VAR3:=MA((V-REF(V,1))/REF(V,1),5);

VAR4:=(C-MA(C,24))/MA(C,24)*100;

VAR5:=VAR4*(1+VAR3);

VAR6:=REF(VOL,1);

VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;

VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);

VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);

VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);

VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);

VAR12:=VAR5>REF(VAR5,1);

VAR13:=VAR5<REF(VAR5,1);

VAR14:=VAR2<REF(VAR2,1);

VAR15:=VAR2>REF(VAR2,1);

VAR16:=VAR8 OR VAR10;

VAR17:=VAR9 OR VAR11;

VAR18:=VAR13 AND VAR14;

VAR19:=VAR16 OR VAR18;

VAR20:=VAR12 AND VAR15;

XG:=LAST(VAR19,7,1) AND VAR20,colorred,STICK;

UP:=CROSS(XG,VAR19) AND VAR20<2.1 AND C>O;

STICKLINE(UP,50,0,4,0),COLOR0000FF;

STICKLINE(UP,50,0,3,0),COLOR6600FF;

STICKLINE(UP,50,0,2,0),COLORFF00FF;

STICKLINE(UP,50,0,1,0),COLORFF99FF;

STICKLINE(UP,50,0,0.3,0),COLORFF3366,;

DRAWTEXT(UP,53,'出击'),colorgreen;

均价线:3*SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1),3,1),colorliblue,LINETHICK2;

你恐慌我贪婪:IF(均价线<=8,30,0),colorred,LINETHICK2;

DRAWTEXT(CROSS(你恐慌我贪婪,8),33,'我贪婪'),colorblue;

JS:=IF(MACD>=0,MACD,DRAWNULL);

MACD:=IF(MACD<0,-MACD,DRAWNULL);

高位:90,DOTLINE,colorlired;

平衡:50,DOTLINE,colorblue;

区间:20,DOTLINE,colorligray;

底位线:5,DOTLINE,colorblue;

DRAWTEXT_FIX(1,0.21,0.42,1,'【关注均价线在底位线区间的数值!!!】'),colorblue;




2、机构利器

////主力动向+主力趋势雷达///
r0:=((IF(ISNULL(ZDMR[-1]),0,ZDMR)+IF(ISNULL(BDMR[-1]),0,BDMR))-(IF(ISNULL(ZDMC[-1]),0,ZDMC)+IF(ISNULL(BDMC[-1]),0,BDMC)))/SHGZG*100;
MA5:=MA(r0,5);
//超买:3.2,coloryellow;//让位趋势决策线
//超卖:0.5,coloryellow;//让位花神线
最小值:=LLV(LOW,10);
最大值:=HHV(HIGH,25);
波动线:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);
平均线:EMA(波动线,3);
主力攻击:=r0-(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)>0 AND 平均线>=REF(平均线,1) AND REF(平均线,1)<REF(平均线,2);
主力撤退:=-((r0+(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)<0) AND 平均线<=REF(平均线,1) AND REF(平均线,1)>REF(平均线,2));
DRAWTEXT(主力攻击>0,1.5,"主进"),colorred;
DRAWTEXT(主力撤退<0,2.8,"主退"),colorgreen;
信息:=平均线>=REF(平均线,1);
走强:=CLOSE>MA(CLOSE,20)AND CLOSE>MA(CLOSE,5);
走弱:=CLOSE<MA(CLOSE,10)AND CLOSE<MA(CLOSE,5);
量:=VOL>MA(VOL,5);
STICKLINE(平均线>=REF(平均线,1),波动线,REF(波动线,1),5,0),colorred;
STICKLINE(平均线<REF(平均线,1),波动线 ,REF(波动线,1),5,0),colorgreen;
d:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 平均线<0.5;
s:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 走强=1 AND REF(走强,1)=0 AND 量=1;
dd:=平均线>2 AND (信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2);
tz:=(信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2) AND MA5<0 AND 走弱=1 AND 平均线>1;
DRAWTEXT(d=1,1.75,'极底'),colorred;
DRAWTEXT(s=1,平均线,'升');
DRAWTEXT(dd=1,平均线,'顶');
DRAWTEXT(tz=1,平均线,'下');
PARTLINE(平均线,平均线>=REF(平均线,1),colorred,平均线<REF(平均线,1),colorgreen);
////机构建仓////
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (M