通达信相对能量指标公式_通达信公式_股票公式
  您的位置:首页 >> 股票公式 >> 通达信公式 >> 文章正文

通达信相对能量指标公式

加入日期:2019-9-21 21:34:59

  顶尖财经网(www.58188.com) 股票公式源码交流:

BIAS:(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
OBV:=BIAS;
P:=5;
A1:=REF(OBV,P)=HHV(OBV,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P); A2:=REF(OBV,P)=LLV(OBV,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P); 上:REF(OBV,BARSLAST(D1)),COLORFF00FF,NODRAW;
下:REF(OBV,BARSLAST(D2)),COLOR00FF00,NODRAW;
向上:CROSS(OBV,上*1.01),NODRAW;
相对能量:=(OBV-下)/(上-下)*100,COLORYELLOW;
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
压力:DRAWLINE(D1,OBV,S11,OBV,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
支撑:DRAWLINE(D2,OBV,U11,OBV,1),COLORGREEN;
下轨:STICKLINE(C>0,下,下,1,0),COLORGREEN;
上轨:STICKLINE(C>0,上,上,1,0),COLORMAGENTA;
DRAWTEXT(CROSS(OBV,上*1.01),上,上),COLORYELLOW;
DRAWTEXT(CROSS(下*0.99,OBV),下,下),COLORYELLOW;
DRAWICON(D1,OBV,1);
DRAWICON(D2,OBV,2);

 

编辑: 来源: