同花顺MACD加强指标公式_同花顺公式_股票公式
  您的位置:首页 >> 股票公式 >> 同花顺公式 >> 文章正文

同花顺MACD加强指标公式

加入日期:2019-9-19 22:05:37

  顶尖财经网(www.58188.com) 股票公式源码交流:

SHORT:=12;
LONG:=26;
MID:=9;
DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
DEA :=EMA(DIFF,M);
MACD := 2*(DIFF-DEA);
Zero : 0;
KDIFF:= DIFF-REF(DIFF,1);
KDEA:= DEA-REF(DEA,1);
KMACD:= MACD-REF(MACD,1);
KDI:MA(KDIFF,2)*100;
KDE:MA(KDEA,2)*100;
KMA:MA(KMACD,2)*100;
CKDI:=ABS(ABS(KDI)-ABS(REF(KDI,1)));
CCKDI:=ABS(ABS(CKDI)-ABS(REF(CKDI,1)));
CKMA:=ABS(ABS(KMA)-ABS(REF(KMA,1)));
CCKMA:=ABS(ABS(CKMA)-ABS(REF(CKMA,1)));
CMA:=ABS(ABS(KMA)-ABS(KDI));
MA5:=MA(CLOSE,5);
CMA5:=ABS(ABS(MA5)-ABS(REF(MA5,1)));
KDITDE:KDI-KDE;
SALE:=KDI>0 AND KMA>0 AND (CKDI<REF(CKDI,1) OR CKMA<REF(CKMA,1)) AND CMA<REF(CMA,1);
BUY1:=IF( (DIFF<DEA AND DIFF>MACD) OR (KMACD<REF(KMACD,1) AND REF(KMACD,1)<0),0,KDI<15 AND KMA<15 AND (CKDI<REF(CKDI,1) OR CKMA<REF(CKMA,1) OR (KDITDE>0 AND REF(KDITDE,1)<0 OR CMA<REF(CMA,1))) );
DRAWTEXT(SALE,KMA*1.20,走),colorwhite;
DRAWTEXT(BUY1,KMA*1.20,入),colorred;

 

编辑: 来源: